[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
URL Resolver Error / Server is not reachable  XML
Forum Index » Air Video Problems and Solutions
Author Message
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

the log is as good as it gets.

NAT-PMP Port Mapper: - response error -5 - recvfrom() failed. NAT-PMP is NOT supported.

that means your router doesn't support NAT-PMP, which is correct. NAT-PMP is only supported by Apple AirPort routers.
From the log it is apparent that router has already mapping for your computer defined
45631 -> 192.168.1.107:45631 (TCP) AirVideoServer
thus Air Video Server doesn't need to map the port.

I'm bit puzzled why it doesn't work. As far as Air Video Server is concerned the port mapping is already there and it reports correct addresses to registry. Are you sure that none of your firewall settings have changed? Can you connect to the machine over local network? Did you install an additional software firewall?
myairvideoe



Joined: 09/14/2009 03:53:52
Messages: 35
Offline

Admin,

I manually port forwarded my ip address and my instance is accessible over 3G. I think the automated port forwarding is the one that's causing the errors.

Am not sure then what is causing the issue Can please you dig down to the source ? I can do my best to give an additional information that you require...

This message was edited 1 time. Last update was at 10/06/2009 17:23:22

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

i already addressed the error in my previous post. The error is to be expected. It happens because your router doesn't support NAT-PMP. NAT-PMP is technology similar to UPnP but created by Apple and used by Apple Airport routers. That error is completely normal and happens with all network without Airport router.

So you can ignore the line with response error -5. Everyeone gets the error unless they have Airport router with NAT-PMP enabled.

As for the port mapping, Air Video asked your router to provide list of port mappings. The list is written to log, you can take a look. One entry in the list maps port 45631 from your router to your computer. Air Video Server sees this entry so it doesn't attempt to remap the port. Perhaps if you disabled automapted port mapping (which causes air video server remove the mapping) and reenable it again it would work (just a guess).

This message was edited 1 time. Last update was at 10/06/2009 17:28:21

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

If automated port mapping is causing the issue (which i really don't see why) you can always turn it off and use manual port mapping if that works fine for you. It might be a glitch in your router's UPnP implementation. Plenty of routers have some unfortunately.
myairvideoe



Joined: 09/14/2009 03:53:52
Messages: 35
Offline

I understand what you are saying.... For me the port forwarding is working now after manually doing it...
The only reason that I could think of is... I had a laptop and computer running the AirVideo server at the same time and I had manually port forwarded my laptop's ip address sometime back and never took it off... So I guess the port was blocked for one ip and that messed up my desktop's connection...

I'm going to disable the manual port forwarding and try the dynamic fowarding one machine at a time...

Thanks for your help! I'm getting more knowledgeable thru this app
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Sometimes when you have manually forwarded port on a router and then forward more ports through UPnP it can confuse it a bit. Perhaps this was your case. If not, worst case scenario, you can still forward all ports manually.
myairvideoe



Joined: 09/14/2009 03:53:52
Messages: 35
Offline

I disabled my manual port fowarding AirVideo port and it started working again.... Thanks for your assistance again....

Just curious, any client/server updates in line in near future??
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

We plan a bugfix update soon but we're waiting for a codesign certificate.
Hilty



Joined: 10/14/2009 18:25:56
Messages: 25
Offline

I too am having an "URL Resolver Error"

I have:
unchecked the auto mapping
Restarted the Air Video Server
Reset my router
And am PINned

I get connection through WiFi, but refuses to connect via 3G.

I am not behind a firewall as yet, and am perplexed by this.

This is a very useful program, but only if it works through 3G as I really only have use of it when not near my computer. I am running on a PC Win XP.

Assistance regarding this issue would be appreciated.

This message was edited 1 time. Last update was at 10/14/2009 22:29:27

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

You have unchecked "Automatic port mapping". Did you configure the port forwarding manually? Because you have to either uncheck "Automatic port mapping" and configure the forwarding manually or leave it checked and enable UPnP on your router (your router must support UPnP).
Hilty



Joined: 10/14/2009 18:25:56
Messages: 25
Offline

I have a NETGEAR WPN824 v2 I have no clue whether or not this supports UPnP

And as far as manually configuring port forwarding? Perhaps you can explain what that is exactly and how to go about doing it? I saw no instructionals regarding this in the tutorial section.

Thanks.

This message was edited 1 time. Last update was at 10/14/2009 22:35:24

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

We don't have router specific information in the tutorial. How to enable UPnP and map ports is different for every router out there. We can't really cover that.

Whether your router supports UPnP and how to enable it if it does should be mentioned in your router's manual. The manual should also show how to setup port forwarding. You can look at the troubleshooting page (http://www.inmethod.com/air-video/connection-problems.html ) to find the information needed to map the port:
Your router either doesn't support UPnP or NAT-PMP or the support is broken. You will need to setup your port forwarding manually:

* On Remote tab in Server properties make sure that "Enable Access from internet" is checked and "Automatic Port Mapping" is unchecked.
* In your router's web administration add new port mapping with following settings:

External Port - the port displayed on Remote tab (45631 by default)
Internal (or Local) Port - same as External Port
Protocol - TCP
IP Address - Your computer's IP address
Hilty



Joined: 10/14/2009 18:25:56
Messages: 25
Offline

Perhaps this can be done by use of No-IP? If so what are the correct protocols?

I am using Jaadu VNC through this. I get full connectivity with Jaadu.

This message was edited 1 time. Last update was at 10/14/2009 22:46:50

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

NO-IP is something different. It's dynamic DNS. You don't need to use that with Air Video, Air Video does that for you when using server PIN. As for Jaadu, I'm not sure how that works for you. VNC would still need port 5900 forwarded.

What you need to so is to login to your router's administration interface, find the section where port mappings are defined and add a new port mapping with the values described in my previous post.
Hilty



Joined: 10/14/2009 18:25:56
Messages: 25
Offline

Crappers, that is not good for me....
Uh in the meantime? You may want to go over to Jaadu's site and rip their instructional/tutorial on how to port forward. They have everything there with concise instructionals and even links to server specific guides. It might alleviate some of the FAQ traffic you deal with. In the meantime I am dead in the water for the moment as I do not know the correct protocols to enter my routers options.
 
Forum Index » Air Video Problems and Solutions
Go to:   
Powered by JForum 2.1.8 © JForum Team