[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
AVS Linux - Download links & information  XML
Forum Index » Air Video General
Author Message
Jospfh



Joined: 11/07/2011 15:58:44
Messages: 1
Offline




@rubiojr: Any chance you will make a package for oneiric (Ubuntu 11.10)?

Thanks, Jos
zerocool5878



Joined: 11/09/2011 23:31:03
Messages: 2
Offline

Hi I hope someone can offer a bit of help. I am new to linux so I may not understand everything you say right away.

I had Kubuntu 11.10 and I could not get Airvideo working. I figured out that it was because it was onneirc and the repo didnt support it.

I then switched to Ubuntu 10.04 and it worked perfect. Icon appeared by the time when I launched it, right click and start server all woprked great.

Today I decided to ditch that and try Ubuntu 11.04 . I checked the repo first to make sure natty had a folder so i knew it was supported.

Install seemed like it went perfect. Edited the properties for my folders.

When i typed airvideo-server in terminal this is what I got



zerocool5878@zerocool5878-NC695AA-ABA-m9515y:~$ airvideo-server
DEBUG: SnapshotCache: Initializing Thumbnail Cache; Java Version: 1.6.0_22
DEBUG: SnapshotCache: Loaded existing Snapshot Index BTree with with 2 items.2011-11-09 18:02:30.386::INFO: Logging to STDERR via org.mortbay.log.StdErrLog
2011-11-09 18:02:30.412::INFO: jetty-6.1.x
2011-11-09 18:02:30.446::INFO: Started SocketConnector@0.0.0.0:45631
DEBUG: PortMapperAction: Scheduling task PortMapperAction$2 (46635017)


Now its really weird because it just hangs there but I can connect and play videos just fine from my iphone. both of my folders show up and it seems great. however the file isn't fully executing because i do not get the tray icon and if I close terminal the connection also terminated. Basically i have to keep that window open and let it scroll code while i use it.

Again I am new to linux so it may be an easy fix I am just too new to know what to do

Any help you can offer would be greatly appreciated.

Mike

This message was edited 2 times. Last update was at 11/09/2011 23:52:13

zerocool5878



Joined: 11/09/2011 23:31:03
Messages: 2
Offline

double post sorry

This message was edited 1 time. Last update was at 11/09/2011 23:51:43

sipace



Joined: 11/15/2011 21:34:51
Messages: 1
Offline

Hi,
I've covered most of the Linux threads on the forum, but still no luck running AVS. I did the installation following http://blog.frameos.org/2011/02/08/installing-airvideo-linux-server-in-ubuntu/
on a machine running Ubuntu 10.04, which I'm accessing via terminal only. The following message appears after trying to run the server:

DEBUG: SnapshotCache: Initializing Thumbnail Cache; Java Version: 1.6.0_20
DEBUG: SnapshotCache: Created new Snapshot Index BTree2011-11-15 21:42:11.519::INFO: Logging to STDERR via org.mortbay.log.StdErrLog
2011-11-15 21:42:11.627::INFO: jetty-6.1.x
2011-11-15 21:42:11.753::INFO: Started SocketConnector@0.0.0.0:45631
DEBUG: PortMapperAction: Scheduling task PortMapperAction$2 (3668766)


I've added the server on Ipad and it sees the folder, but shows no files.

Any advice anyone?

Thanks!
duceduc



Joined: 08/09/2011 07:05:58
Messages: 13
Offline

Can someone tell me how I can view my live log file while streaming a video? I want to know if my computer or my router connection is causing the constant stutter on videos that are over 720p encoded.
freemovietag



Joined: 11/27/2011 17:11:13
Messages: 1
Offline

thanks..sir for give me...i m newbie here..

Download Movies Free
[WWW]
aion1223



Joined: 07/15/2011 01:36:54
Messages: 1
Offline

I found that an extra port aside from 45631 should be open, probably, in some cases.

I am posting this since it seems to be hard to figure out. At least, it was to me. I am hoping this tip helps you.

In my case, AVS was stuck at the beginning of live conversion. Since I could traverse the directories and even play mp4 files without live conversion, I didn't think it's a firewall problem at all. I guessed, the only server is AVS and the unique port that it uses is 45631. Therefore, we are fine if 45631 is open. However, that wasn't true.

Due to that I found some messages like 'fail to connect', I stopped the entire firewalls. Then, AVS worked. It seems that, AV client talks to AVS to traverse directories but to customized FFMpeg's independent server to encode the chosen file on the fly. There is an extra port that the FFMpeg server listens. In my case, it was 46631.

If AVS stuck with rare error messages, then, opening the extra port may help some of you.

Thanks.

%P.S. Most of them are, how can I say, my induction. The facts are that AVS wasn't working when I didn't open 46631 and begun to work after it's opened.

This message was edited 3 times. Last update was at 12/06/2011 22:44:59

XaRz



Joined: 12/21/2011 18:48:25
Messages: 4
Offline

Hello folks!

First thanks for your efforts and info.
I've been able to start and correctly run the AVS in ubuntu 11.10..BUT live conversion is too slow and stops at 5 seconds of streming.
First I was thinking about hardware problem but my AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ with 2Gb RAM not reaching 100% of cpu use (in fact no traces of ffmpeg in 'ps-aux|grep ffmpeg')

Any hints where I must look?

(I've the Airvideo server working in 2 macs without problems..but I've the BIG movie content in the ubuntu server..)

Thanks in advance.

XaRz



Joined: 12/21/2011 18:48:25
Messages: 4
Offline

I've started a manual session (not the sudo start airvideo command) and I get this log:



Anything wrong in this log? The video stalls every 8 seconds aprox...perhaps need more cpu?

nawunk



Joined: 04/03/2011 15:24:39
Messages: 7
Offline

Any chance on updating the linux version to 2.4.5-beta7 for 10 bit support?
NillNickson



Joined: 02/12/2012 08:16:15
Messages: 1
Offline

Hey. thanks for the information. Its great

shoe lifts
elevator shoes for men
tall shoes
Map



Joined: 04/11/2010 13:26:30
Messages: 2
Offline

It doesn't look like we can expect an updated Linux version anytime soon, does it? It's pretty calm in this thread for some time, even though 10bit would be very nice to have on Linux as well
cadeng



Joined: 03/08/2012 03:56:43
Messages: 1
Offline

I would love to see 10 bit support adopted into Linux Airvideo server, one of my main considerations picking an iOS streaming platform was Linux support and with the iPad 3 released I was definitely hoping for some 10 bit encoding.
jj88



Joined: 03/09/2012 10:31:38
Messages: 1
Offline

very useful post, thanks!!

posizionamento motori di ricerca
Shutzy



Joined: 03/13/2012 11:12:01
Messages: 2
Offline

Hello,

first i want to mention that i posted my question already under Air Video Problems and Solutions, but unfortunately without reply yet. This thread seems to be anyway dedicated to the Linux server version and i might find easier help here.

Now, here to the question


Hi all,

i have 2 different air video servers in my network environment, the 2.4.3 version under Windows XP and the Alpha 6 release of the Linux Version on Ubuntu 11.10 (installed via rubio repository).

Under Windows version i haven't met any problems so far and i'm very happy with the server software and the client app on my Iphone 3G (iOS 4.2.1). I was very thrilled as i saw that there is a Linux version of air video server available. In this way i hoped to don't have another desktop computer running all the time just for the air video server and move this to my little Linux home server. But i meeting some problems that need to be erased first before that could happen. The streaming and browsing part works perfectly nice, but the client crashes if i try to playback a file which was converted by this very server (it appears "preparing video", the screen turns black and the nothing... i'm back on my iOS screen the application crashed). But on the other hand i have no problem to playback converted files which were done by the Windows version of the server.

Unfortunately, there is no log file to look into why the application crashed. Also the server doesn't show any indication (the conversion works without any error message). Therefore, I don't know where to start looking for the problem. The converted file is also playable in VLC, so it is not producing a corrupted file... only an incompatible file to the client app player. Any input from your side would be much appreciated.

Maybe it could have something to do with the installation? Since the mpeg4-ip package was deleted from the Ubuntu 11.10 repositories the installation was not complete and i had to manually install the necessary packages for mp4creator from the previous 11.04 release. Did i maybe miss something?

There is also another but secondary problem: The files converted under the linux server are smaller in size and worse in quality compared to the files converted under the Windows server version, but the global conversions settings are the same for both servers... 100% quality for Offline conversion. Is there a way to tweak the linux server conversion process to get the same result as under the windows server conversion process?

Sorry for the long explanation, but i thought it's better to give detailed information to my problem here.

I say already many thanks for your answers

Cheers

Stefan
 
Forum Index » Air Video General
Go to:   
Powered by JForum 2.1.8 © JForum Team