[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Air Video Server 2.4.5-beta6 released  XML
Forum Index » Air Video Announcements
Author Message
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Does it happen with files that have accents on characters?
justviewer



Joined: 05/14/2011 06:40:02
Messages: 5
Offline

Admin wrote:Does it happen with files that have accents on characters?


Yes, the item is not displayed if the name contains non-English characters, such as Chinese.
This happens for both file and directory.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

can you please open the "Terminal" application (Applications/Utility/Terminal) and paste here the output of following command?

echo $LANG
justviewer



Joined: 05/14/2011 06:40:02
Messages: 5
Offline

Admin wrote:Hi,

can you please open the "Terminal" application (Applications/Utility/Terminal) and paste here the output of following command?

echo $LANG


Hi,

$LANG is empty.

I will post the whole "env" to you via PM.

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

this is very helpful, thanks. Any chance you can try the following two commands in terminal?

export LANG=en_US.UTF-8
/Applications/Air\ Video\ Server.app/Contents/MacOS/Air\ Video\ Server


(that is assuming you have installed Air Video Server to /Applications)
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Actually, now I got your PM, the LC_CTYPE env variable should suffice here, I'm really not sure why it doesn't.
justviewer



Joined: 05/14/2011 06:40:02
Messages: 5
Offline

Admin wrote:Hi,

this is very helpful, thanks. Any chance you can try the following two commands in terminal?

export LANG=en_US.UTF-8
/Applications/Air\ Video\ Server.app/Contents/MacOS/Air\ Video\ Server


(that is assuming you have installed Air Video Server to /Applications)


Yes. It works.

I can see all files and directories with the LANG environment variable.

Thank you.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Actually, it's probably not the LANG variable. It's the LC_CTYPE that terminal (by default, can be turned of in advanced preferences) puts in the env on startup. You can try this by launching Air Video Server from other terminal tab and not setting the LANG variable upfront.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Can you please try the following build and let me know if it helps?

https://s3.amazonaws.com/AirVideo/Air+Video+Server+2.4.5-beta6u2.dmg
justviewer



Joined: 05/14/2011 06:40:02
Messages: 5
Offline

Admin wrote:Can you please try the following build and let me know if it helps?

https://s3.amazonaws.com/AirVideo/Air+Video+Server+2.4.5-beta6u2.dmg


It works well.

To validate it, I started it in Terminal which unset LANG and unset LC_CTYPE.
All files are listed.

FYI. I tested the previous beta6u1 version. You are right.
Either LC_CTYPE=UTF-8 or LANG=en_US.UTF-8 was set, the server works well.
Only if both of them were unset, some file disappeared.

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Thanks for testing it, I updated the links in original post, anyone that has problems with files not appearing in OS X please redownload the update2 and let me know if it helps.
paulf



Joined: 05/13/2011 07:56:57
Messages: 2
Offline

Admin wrote:Thanks for testing it, I updated the links in original post, anyone that has problems with files not appearing in OS X please redownload the update2 and let me know if it helps.


Yes, now all Files are displayed.
Many thanks for the great work!
fryheit



Joined: 05/14/2011 00:08:28
Messages: 2
Offline

Admin wrote:Hi,

is there anything written to console while the app "freezes"? Can you open the Console (Applications/Utilities/Console) application before you start Air Video Server to see what's written in the log?


14.05.11 11:52:15 [0x0-0x2c02c].com.inmethod.AirVideoServer[453] Loading MiniAgent in FetchAbsentClassesMode

that's it

maybe my system is full of crap and something is disturbing air video server.. maybe i should reinstall mac os x
little snitch didn't even ask for permission so i think air video server isn't properly starting at all

here's the analyzation of the activitymonitor, maybe it helps: http://dl.dropbox.com/u/2192953/airvideo.rtf
danielooi


[Avatar]

Joined: 10/11/2010 09:38:00
Messages: 1
Location: George Town, Penang, MY
Offline

running windows 2.4.5-beta6u2 now on my intel atom, windows 7 starter, working fine so far...
but mac os x 2.4.5-beta6u2 required intel only? previously mac os x 2.4.5-beta5 able to run on my good old iMac G5, Mac OS X 10.5.8 but iPhone unable to connect. AirVideo to drop PPC support?

http://twitter.com/danielooi

This message was edited 3 times. Last update was at 05/14/2011 15:01:59

[WWW]
blackrosestudios



Joined: 05/14/2011 19:40:40
Messages: 2
Offline

If you are running most current upgrade to Air Video 2.4.8 make sure you also upgrade to this new neat or videos will not play.
 
Forum Index » Air Video Announcements
Go to:   
Powered by JForum 2.1.8 © JForum Team