[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Air Video Server 2.1.8-beta8 released  XML
Forum Index » Air Video Announcements
Author Message
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

I'm pleased to announce that new Air Video Server beta version is available.

You can download it for Mac OS X Leopard and Microsoft Windows.

Improvements in this release:
* Subtitle Support! SRT, SSA, SUB (MicroDVD), SMI (Experimental) formats are supported. Text subtitle track in MKV files are also supported.
* 64bit transcoding on 64bit Macs
* Windows Installer should configure proper rules for all firewall profiles
* More UPnP workarounds for broken routers
* Greatly improved unicode support on Windows

Changes since beta 7:
* Fixed FFMpeg problems on OS X 10.5 Leopard
* Fixed problems with Windows thumbnail generation (caused by missing msvcr90.dll)
* Subtitle size change on Windows shouldn't require server restart

Changes since beta 6:
* A/V sync fixes
* Experimental support for SMI subtitles
* Added option to adjust subtitle font size
* Stability improvements

Changes since beta 5:
* Option to disable embedded subtitles
* Compatibility with OS X 10.5 Leopard
* Fixed startup problems on OS X
* Important unicode fixes on Windows - Air Video can now be installed in folder that contains unicode characters, also conversion should work in unicode folders

Changes since beta 4:
* Overlapped subtitles should be supported properly.

Changes since beta 3:
* Fixed problem when Air Video Server froze on startup / shutdown.

Changes since beta 2:
* Fixed version number in Windows installer
* Fixed subtitle loading bugs
* Stability improvements

Please keep in mind that subtitle support is new. Feedback is very welcome. Also this build DOES NOT SUPPORT PowerPC Macs.
This is a beta version so treat it as such. Things might not work quite as expected

Update: If the accented characters don't show right you need to adjust subtitle encoding in Air Video Server properties.

This message was edited 1 time. Last update was at 12/31/2009 09:05:42

dadavo



Joined: 10/18/2009 07:51:30
Messages: 16
Offline

Is this release optimized for multi-core CPUs?
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

It contains regular FFMpeg build. It can still take advantage of multi-core CPUs, but it might not be able to load all CPU cores 100% for certain videos. Unfortunately the multi thread version of FFMpeg did cause serious AV sync issues as well as problem with seeking in TS files (which you have reported).
dadavo



Joined: 10/18/2009 07:51:30
Messages: 16
Offline

Yes I noticed the seeking was working. Too bad, while this does fix my seeking issue my original problem of buffering every minute or so reappears. Oh well.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Does the rebuferring happen on local network or over 3g?
dadavo



Joined: 10/18/2009 07:51:30
Messages: 16
Offline

Admin wrote:Does the rebuferring happen on local network or over 3g?


Both. I monitor the CPU usage and it never exceeds 70% with this version of FFMpeg. The multi-threaded versions always registered 100% usage but streamed smoothly. Though it didn't seem like 100% was being used as running other background programs ran without stuttering.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Even if the process says it uses 100% of CPU the operating system scheduler will give CPU time to other processes as well. What is your computer configuration and is the format and resolution of input videos? Btw, if you increase ffmpeg.exe process priority during playback (in task manager), does it get any better?
insanary



Joined: 12/20/2009 05:51:58
Messages: 3
Offline

thanx about your quick response..
but, there are little bit problem of my macmini with leopard..
i don't see any subtitle...... sub, smi every subtitle..
so i check olderversions of this server application for mac..
but also no...

i check that subtitle section in properties..
and than check logs section..

subtitles log are nothing.
Mmm.. what's problem to me..

This message was edited 1 time. Last update was at 12/21/2009 18:27:32

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Does your subtitle have the exact same name as the video file? (except for the extension of course).
dadavo



Joined: 10/18/2009 07:51:30
Messages: 16
Offline

Admin wrote:Even if the process says it uses 100% of CPU the operating system scheduler will give CPU time to other processes as well. What is your computer configuration and is the format and resolution of input videos? Btw, if you increase ffmpeg.exe process priority during playback (in task manager), does it get any better?


I changed both FFMpeg and AirVideo processes to Realtime Priority with no other applications running in the background. It made little diffrence. I have my settings for AirVideo on my iPhone to stream at about 25% - 40% quality. The videos are the same as I uploaded before. 12.5 MB/s H.264 ts files. The multi-theaded FFMpeg did a very good job of giving me smooth streaming. Thanks for any help or advice you can give me.

Intel T2600 2.16GHz Core 2 Duo
3GB RAM
Windows XP Service Pack 3
500GB x2 in Raid 0

This message was edited 1 time. Last update was at 12/21/2009 23:47:54

mudden



Joined: 12/22/2009 14:19:50
Messages: 4
Offline

Hi!

Thank's for an excellent software!

Unfortunately the server stopped working.
Running Beta8 the service loads but does work.
The console does not load.

Running w2k8r2

Tried uninstall/reinstall/reboot. Versions 217, 217b7 and beta 8.

Regards,

Jocke
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

I'm really not sure what exactly doesn't work. Does the application start? Can you see the icon in menubar? Is the AirVideoServer.exe process running?
mudden



Joined: 12/22/2009 14:19:50
Messages: 4
Offline

Admin wrote:Hi,

I'm really not sure what exactly doesn't work. Does the application start? Can you see the icon in menubar? Is the AirVideoServer.exe process running?


Hi!

Yes the process runs
No the Console (Icon) doesn't

Regs,

Jocke
mudden



Joined: 12/22/2009 14:19:50
Messages: 4
Offline

mudden wrote:
Admin wrote:Hi,

I'm really not sure what exactly doesn't work. Does the application start? Can you see the icon in menubar? Is the AirVideoServer.exe process running?


Hi!

Yes the process runs
No the Console (Icon) doesn't

Regs,

Jocke


Btw,

Every time I try to start the server it loads another AirVideoServer.exe process
Looked in the event viewer but haven't found anything related. That could be more my lacking knowledge of using event viewer thou...
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Okay,

try the following:
Open Task manager
kill all AirVideoServer.exe processes
Go to <your-home-folder>\Local Settings\Application Data\AirVideoServer

delete the conversionStatus2 file.

<your-home-folder> is usually in C:\Documents And Settings
 
Forum Index » Air Video Announcements
Go to:   
Powered by JForum 2.1.8 © JForum Team