[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
AirVideo fails to play TS files with multiple audio streams  XML
Forum Index » Air Video Problems and Solutions
Author Message
plnet



Joined: 09/06/2009 08:56:35
Messages: 19
Offline

Hello everyone,
the problem is in the title. I'm recording videos from DVB-T, and AirVideo would play them only if there's only one language/audio stream in that recording. As for the files with multiple audio streams, I've managed to play some of them by changing conversion settings such as resolution and zoom level, but for most files it says, "The movie could not be played". However, you can seek through the video, and the thumbnail is also being generated.
I can upload such file somewhere if you want me to, so you could investigate the issue.
Thanks in advance!
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

plnet wrote:Hello everyone,
the problem is in the title. I'm recording videos from DVB-T, and AirVideo would play them only if there's only one language/audio stream in that recording. As for the files with multiple audio streams, I've managed to play some of them by changing conversion settings such as resolution and zoom level, but for most files it says, "The movie could not be played". However, you can seek through the video, and the thumbnail is also being generated.
I can upload such file somewhere if you want me to, so you could investigate the issue.
Thanks in advance!

It would be great if you were able to upload the file somewhere and send me the link (as private message).
plnet



Joined: 09/06/2009 08:56:35
Messages: 19
Offline

I believe you get plenty of PMs every day, I think it's safer to post the links here (there's nothing private in these videos, after all):
This is the example of video that won't play at all;
and this video does play (although it also has 2 audui streams), but the sound is laggy; there's no pleasure of viewing such video.
Regards,
ML

This message was edited 1 time. Last update was at 09/07/2009 17:11:49

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

have you tried the latest Air Video version (2.1.2-beta3)? I tried the videos you've sent me and they played well. Although it could also be because I've tested it with newer client version (that is being reviewed by Apple), although that's not very likely.
plnet



Joined: 09/06/2009 08:56:35
Messages: 19
Offline

Hello again,
yes, I have tried the latest server app but with no luck, and I'll see what a client update brings us
Please try this file - I've double-checked it, and it really won't play no matter how I try.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

I was able to fix the audio stream problem with the last file but I'm not able to fix the stutter. There seems to be something not completely right about the x264 track that makes ffmpeg choke on it.
plnet



Joined: 09/06/2009 08:56:35
Messages: 19
Offline

Well, yes, there is somenting not completely right with these 2 channels from which these recordings are being made. They have 1 or 2 empty audio streams - e.g. the language is displayed in the list, but there's no audio stream on that PID. It's a DVB issue and I'm trying to resolve it with my DVB provider, but they won't fix it (at least yet)
 
Forum Index » Air Video Problems and Solutions
Go to:   
Powered by JForum 2.1.8 © JForum Team