[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Double NAT - What it is and how to resolve it  XML
Forum Index » Air Video Problems and Solutions
Author Message
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

What is NAT

The number of available IP addresses on internet it limited. To get around this a concept of NAT (Network Address Translation) was introduced. With NAT only the router needs to have public IP address (also called Gateway, usually a DSL or Cable Modem). All devices behind NAT router have private IP addresses - usually starting with 192.168 or 10. These addresses are only valid within the router network.

A quite common example is a simple network with one gateway (say DSL or Cable modem). The gateway has a public (WAN) IP address and does NAT. All computers connected to this gateway get assigned a private IP address. The gateway takes care routing the data from / to computers connected to it. To make a computer connected to gateway accessible from interent a port forwarding setting is required. If the gateway supports UPnP or NAT-PMP protocol, Air Video Server can transparently setup the port forwarding for the user. Otherwise manual port forwarding is required (port 45631 / TCP).

This scenario represents a single level of NAT (just one router on network that does network address translation). Unfortunately it often isn't this simple.

What is double NAT

Double NAT is a scenario where multiple routers on network are doing network address translation. Common example is a Cable or DSL modem, to which a Wi-Fi router is connected. Both modem and router have NAT enabled. Computers on the network are connected to Wi-Fi router.

Even if port forwarding is setup on Wi-Fi router, the computer is not accessible from internet, because the WiFi router itself doesn't have public IP address. It has a private IP address within the network of DSL/Cable modem. There are multiple ways to resolve this, unfortunately none of these is a silver bullet. It depends on concrete network setup to determine which one is appropriate.

The solution below expect the following (most common) scenario: A modem (DSL, Cable, Fiber, etc) and a Wireless router connected to the modem.

Both the wireless router and the modem have web administration interface, each can be configured with a web browser. You might need to consult your router and modem manual to find out the IP address on which the administration interface is available.

Possible Solutions:

1. Setup PPPoE connection between the wireless router and modem

This is the most robust solution, unfortunately not all ISPs provide enough information for this to be setup easily

PPPoE can be usually setup in the wireless router's WAN settings. There are usually multiple options to configure the WAN connection of wireless router, amongst which are DHCP and PPPoE. DHCP is no good here, as it results in private IP address assigned to the WiFi router. PPPoE is better, because it bypasses the NAT in the modem, however it might need login and password information which the ISP might not provide.

2. Put the wireless router in bridged mode

Bridged mode on wireless router means that NAT and DHCP functions on it will be disabled. Some router call it bridged mode, some simply allow you to disable NAT and DHCP. Unfortunately some WiFi routers simply don't support bridged mode at all.

If you manage to switch router to bridged mode, all port forwarding needs to be configured on the modem (either automatically if it supports NAT-PMP, or manually).

3. Put the wireless router in modem's DMZ

DMZ (demilitarized zone) is a common feature of router that allow to chose one client to which all traffic is forwarded. If your modem supports DMZ, this might be solution for you:

1. Find out the WAN address of wireless router. For this you might need to log in to the WiFi router admin interface and look at the Status page (most router's have status pages which show relevant information about the WAN connection).

2. Log in to the modem web administration interface, find the DMZ settings and put the WiFi router's IP WAN address there.

Note that with this solution you will still get a double NAT warning in Air Video Server, but if the port forwarding on Wireless router is setup correctly, things should work.

4. Forward the port 45631/TCP in the modem to the router

This solution is similar to [3], except that instead of putting the WiFi router to modem's DMZ only one port is forwarded.

1. Find out the WAN address of wireless router. For this you might need to log in to the WiFi router admin interface and look at the Status page (most router's have status pages which show relevant information about the WAN connection).

2. Login in the modem web admin interface and configure port forwarding of port 45631 (protocol TCP) to the address from router's status page

Note that with this solution you will still get a double NAT warning in Air Video Server.

Still doesn't work?

If you have configured the port manually, make sure that "Automatic Port Mapping" option in Air Video Server properties is turned off.

Should you still have problems getting remote support working, you can contact us using email at support (a) inmethod.com . However to be able to help you, we will need as many information about your network as possible. That includes the following:

1. Remote support log. The log is available in Air Video Server properties - "Logs" tab. Note that there are multiple logs, you need to chose the one called "remote support". Copy the log and paste it to email. It's good idea to restart the server, wait for it to initialize and then refresh and copy the log.

2. Screenshot of relevant router configuration and status page

Please take the screenshot of modem's status page and router's status page. If you have configured any port forwardings, take the screenshots of port forwarding setup as well. The more screenshots the better. And you can attach the screenshots directly (or zip them), there's no need to embed them in word document.
Chauham



Joined: 01/25/2011 09:22:21
Messages: 3
Offline

Hi,

I recently had Air video server remote working on my IMAC with MAC OS 10.5, and could stream over the Internet with my IPAD with no problems. Since I upgraded the OS to Snow Leopard, I am getting the Double NAT issue. I have run through all of the tests you describe to fix it, but it still does not work. Works fine on my LAN with wifi. Can you advise, thanks.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

The OS update should not have any impact on the double NAT issue. To be able to help you I'd need to see the remote support log. Please send it to support(at)inmethod.com
Chauham



Joined: 01/25/2011 09:22:21
Messages: 3
Offline

Hi, I have just turned off my Airport Express off, and the Air Video remote works fine, as soon as I turn it on again I get the same Double NT issue.

See below log file:

[log removed]

My Airport Express setting are as below:

AirPort is connected to Mahesh Chauhan's Network and has the IP address 10.0.1.7.

Any ideas?

This message was edited 1 time. Last update was at 01/25/2011 20:14:04

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Please don't post the remote support log here. Send the log and message to support (at) inmethod.com
geigera



Joined: 02/05/2011 18:58:21
Messages: 1
Offline

THIS worked for me. I did it with a non-airport express (WRT600N) Linksys. and the Uverse standard modem/router.

http://discussions.info.apple.com/message.jspa?messageID=12505917

Hope it helps!
CDNinKS



Joined: 07/25/2011 14:54:01
Messages: 1
Offline

I had the same problem with my Airport Extreme. Put your Airport into "bridge" mode. That will solve the double NAT problem.
utilityteach



Joined: 07/26/2011 05:56:17
Messages: 2
Offline

Hi Admin,
Recently purchased AV for iPad2. I'm fairly tech savvy and can usually read enough to resolve issues but not this time.

When I go to the remote tab in AV server on my computer, it says that Warning" Possible double NAT detected. when I have the "automatically Map Port" box selected. When I run the test connection, it says "Your Air Video server instance is NOT accessible from internet." I unplugged the modem that has all of our laptops, computers and printers networked. (based on what I had read about modems and wireless modems) I still have the wirelss modem running. When I have "enable Acccess from internet" checked and only that...I am able to access videos from my iPAD through AV and it all seems to work as it should from within my house on my wireless network. Took it to Barnes and Noble today to check it from another wireless location, and it said that the "tracking" was not working...

My ultimate goal: be able to tether my iPad to my iPhone to use it as a wireless hotspot so that we can access videos while on the family road trip. AT&T is my provider.
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

If you get the "Tracker service down" message the most likely explanation is that the network is too restricted and doesn't allow Air Video to communicate on port 1112 (which our tracker service uses).
utilityteach



Joined: 07/26/2011 05:56:17
Messages: 2
Offline

So what do I do to fix that? Am I crazy to think that I could tether my ipad to an iphone and use AV while driving in a car?
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Well, I really don't think it's a good idea to use Air Video while driving, but you need some kind of internet connectivity to get it working.
jyurong



Joined: 10/07/2011 07:06:06
Messages: 1
Offline

I currently live in an apartment complex and do not have direct access to the modem (the building is wired for ethernet). Is it possible for me to change settings on my router alone (linksys DIR 655) to solve the issue?
Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

if your router doesn't have a public external IP address you will not be able to access Air Video Server from internet.
Patjuhr



Joined: 11/21/2011 22:11:28
Messages: 1
Offline

Hi,

First off I want to thank you for this threat. It helped me get my ps3 to NAT2. I did it with just putting the IP-adress of my router in the DMZ of my modem.
Now, yesterday my NAT-type went from 2 back to 3.
I didn't know what happend and took a look in both my router and modem.

I think I figured out what the problem is. I assume my router got a dynamic IP-addres which has changed yesterday. Is that possible?

And if so, how can I get my router a Static IP-adress? I've tried to do that in de web browser, but then it says I need information given by my ISP. I doubt if that helpes.
Can't you just assign the static IP-adress by yourself?

I'd would like some help.

This message was edited 1 time. Last update was at 11/21/2011 22:17:52

Admin



Joined: 08/23/2009 08:49:34
Messages: 8705
Offline

Hi,

You should be able to assign the router static IP address in settings, what information exactly does it require from your ISP? The router shouldn't require anything like that.
 
Forum Index » Air Video Problems and Solutions
Go to:   
Powered by JForum 2.1.8 © JForum Team