[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Messages posted by: glynor
Forum Index » Profile for glynor » Messages posted by glynor
Author Message
With the new updated iPad client, my H264 .ts files from my Hauppauge HD-PVR will no longer seek properly. The files play fine if you don't try to seek them at all (with Live Conversion), but if you touch the seek bar at all, they stop playing and just say "loading" forever. I'd seen this behavior before on my iPhone when I switched to the beta versions of the server, but reverting back to the current stable server fixed it. However, now that I've updated the client on the iPad, the same thing is happening even with the old stable server version. I tried updating to the new beta6 version of the server (I'd previously seen the issue with beta5 and maybe beta4 before that), but it didn't help.

This makes AirVideo much less useful for me, because the a LOT of my files are from the HD-PVR...

PS. Sorry I didn't report this before... I've been very busy with a new baby, and it slipped off of the "to do" list.
I actually came here to make basically this exact comment, but I searched and found someone beat me to it.

I just wanted to say thanks, as well. AirVideo is really probably my favorite app on my iPhone, if I was forced to choose, and is certainly worth the unbelievably low price. Next to the browser and email, AirVideo is easily the most used app on my phone.

Great work.
I can't test with an iPad 1 because I don't have one. But I do have the digital adapter on the way, and I can test with my iPhone 4. I'll try to post back when it comes in.
Shield wrote:I continue to have this problem every time I use Air Video over 3G. I must do a complete shutdown/reboot of my iPhone 4 and then Air Video will work over 3G. This needs to be done every time I want to watch a video. It connects to my home computer just fine, and lets me scroll through my video library...but when I select to play a video Live Conversion it starts to load, then goes black and bounces me back to the menu screen. When I reboot my iPhone 4, it will then play the video over 3G. Over Wifi, everything works perfectly...only trouble is with 3G.


After much more extensive testing, I've determined that this is essentially what I'm seeing. Rebooting the iPhone 4 usually fixes it for a little while, but not always. There have been times where I had to reboot the phone 2-3 times before AirVideo would work again via 3G.

In addition to having trouble actually starting video playing back, as described above ("starts" then immediately closes and goes back to the file listing), I'm also occasionally seeing issues connecting to the Server PIN altogether. When this happens, it will tell me "the remote server closed the connection" and then kick me back to the server list. When this happens, you cannot connect to ANY remote server no matter what the address or type. However, rebooting the phone fixes it.

Incidentally, I have tried manually closing AirVideo via the iOS Multitasking Menu (tap-hold and then hit the minus), when trying to solve both of these issues and it does not help. You MUST reboot the entire phone to recover from the issues.

I am absolutely happy to provide remote access to my AirVideo server if it helps track down the issue. I should also mention... I have been able to reproduce the issue on my wife's iPhone 3GS, so it does not appear to be iPhone 4 specific.
They actually just turned on 3G in my area, so now I am trying to test more thoroughly.

I've had it both work, and fail, in the same areas on the same days. Rebooting the phone does seem to sometimes fix it, but not other times (and it seems to be prone to "breaking" again without warning).
I'm happy to grant you access to my server when I get back home from traveling tomorrow. However... I have news that might shed some light. First, to answer the question, yes, I did try rebooting both the phone and server. BUT... I've just tested via 3G again today, and it worked fine all the sudden with no reboots or config changes at all.

What I'm wondering is... The timing is suspicious. It didn't work during the holidays (when cell networks were under heavy strain), but now magically does post Christmas? Now, I'm in NY now and I was in NJ and PA before, so it could also be a regional thing. But, it could also be AT&T blocking the video traffic itself to reduce load during a time they know will see heavy usage...

Unfortunately, where I'm heading we are stuck in EDGE land so it will be tough for me to test tomorrow.

EDIT: Actually, I was mistaken. I'm still in NJ, right near one of the first places I saw the issue last week.
Tried it out today. No matter what the bitrate is set to, it still will NOT stream over 3G on my iPhone 4. Again, it works fine via remote WiFi. I didn't test with manual resolution settings.

And, FYI, I had 5 bars at the time, FWIW.
I'm having this exact issue. AirVideo works perfectly over many different remote WiFi networks. When I try to use it via 3G, it logs me in and allows me to browse the available content, but when I start to play a video the same thing described here happens. I'm also using an iPhone 4. My wife has a 3GS too, but I haven't been able to test it out on her phone yet.

I can't find the Global Conversion Settings anywhere... Where exactly are these located?

EDIT: Nevermind, I found them. Resolution is set to Automatic and everything else is set at the defaults. Should I try bumping down the 3G allowed bitrate by a notch, perhaps?
I think I've mentioned this before, but I would absolutely LOVE a Windows (and OSX) client. I'd happily pay for a $20-$30 license for it too. Identical resolution and everything to the iPad would be fine.

AirVideo is just absolutely amazing.
Ha ha ha! Wow. I feel dumb. Sure enough, the mute switch is on.

Oops.
Okay, this is odd...

I'm one of the lucky preorders and got my new iPhone 4 today. I tested out AirVideo on it, of course. It works great, except for one thing... The audio doesn't work IF you are NOT using headphones. In other words, the sound does not work via the built-in speaker. The Volume control slider just isn't there at all, as though the video doesn't contain an audio track (or as though you are using an external set of speakers that connect via the dock connector). This applies to all of my videos, all of which still work on my 3G and my wife's 3GS. If you plug in a set of headphones, the Volume slider re-appears and the sound works fine through the headphones.

I haven't tried using the phone in my external dock-connector speakers yet, but I can test them later if it would help.
Thanks. I came wondering the same thing (realizing that FFMPEG supported OGM containers just fine).
I'd really LOVE to see this feature as well. It would be perfect for using AirVideo on Airplanes and other similar occasions where network connections are not available or flaky. To be able to set AirVideo to download a couple of videos from your house (or hotel room with WiFi) before you leave for a flight, would be unbelievably awesome.

BTW... Thank you so much for making this wonderful product. AirVideo is one of the best applications I have on my iPhone. I must say, when I first read about it, I was a bit skeptical. But it has worked unbelievably well for me over the past month or so since I first purchased it. I have a fairly powerful server at home, and it even does absolutely fine at on-the-fly transcoding my HD-PVR recordings from home off of my BeyondTV system. On a recent trip, I was watching the Olympics right after the "episode" finished airing from an airport in Atlanta. It felt like the future.
 
Forum Index » Profile for glynor » Messages posted by glynor
Go to:   
Powered by JForum 2.1.8 © JForum Team