[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Messages posted by: unknown_inc
Forum Index » Profile for unknown_inc » Messages posted by unknown_inc
Author Message
This feature isn't available - yet...
Hi. The only thing you have to do is to "port forward" 45631 to your AirVideoServer. Make sure that the AVS doesn't block that port number, i.e. a firewall.

Good luck!
Anyone can post questions here if they want to...
Here you will find download links and other useful information regarding AVS on Linux.

For getting the AVS (AirVideoServer) for Linux up and running, see the following step-by-step guide - http://wiki.birth-online.de/know-how/hardware/apple-iphone/airvideo-server-linux

AirVideoServer Alpha versions:
AirVideoServerLinux Alpha 1 - http://inmethod.com/air-video/download/linux/alpha1/AirVideoServerLinux.jar
Mirror link via FileSonic - http://www.filesonic.com/file/19744241/AirVideoServerLinux1.jar

AirVideoServerLinux Alpha 2 - http://inmethod.com/air-video/download/linux/alpha2/AirVideoServerLinux.jar
Mirror link via FileSonic - http://www.filesonic.com/file/19744315/AirVideoServerLinux2.jar

AirVideoServerLinux Alpha 3 - http://inmethod.com/air-video/download/linux/alpha3/AirVideoServerLinux.jar
Mirror link via FileSonic - http://www.filesonic.com/file/19744335/AirVideoServerLinux3.jar

AirVideoServerLinux Alpha 4 - http://inmethod.com/air-video/download/linux/alpha4/AirVideoServerLinux.jar
Mirror link via FileSonic - http://www.filesonic.com/file/19744345/AirVideoServerLinux4.jar

AirVideoServerLinux Alpha 5 - http://inmethod.com/air-video/download/linux/alpha5/AirVideoServerLinux.jar
(Needs updated FFMpeg build)

AirVideoServerLinux Alpha 6 - http://inmethod.com/air-video/download/linux/alpha6/AirVideoServerLinux.jar
(Needs updated FFMpeg build)

AirVideoserverLinux 2.4.6-beta3 - http://s3.amazonaws.com/AirVideo/Linux-2.4.6-beta3/AirVideoServerLinux.jar
(Needs updated libav build)

FFMpeg configure command line:
./configure --enable-pthreads --disable-shared --enable-static --enable-gpl --enable-libx264 --enable-libmp3lame

libav configure command line (for 2.4.6-beta3):
./configure --enable-pthreads --disable-shared --enable-static --enable-gpl --enable-libx264 --enable-libmp3lame --enable-nonfree --enable-encoder=libfaac


What hardware is recommended?
- DualCore 2.x GHz

What kind of hardware does it work on?
- Asrock ION 330HT-BD with Dual Core Atom 330 and nVidia ION


This post will be updated with new information now and then, so check back for updates
stough wrote:So, Unknown... Any testing with Alpha 4?

Also, re: Multithreading. The ffmpeg from this site compiled as directed has --enable-pthreads, but I think that you need to tell ffmpeg how many threads to use, I think. It would be nice if the properties file allowed additional arguments to be passed to ffmpeg...

I'll be trying out alpha 4 this evening and will post my findings.

Cheers,
Tim.


I wasn't aware of the Alpha 4 build. I will try that right away... Post my findings in a bit. By the way, some kind of version history could come in handy. And a download link post...
Where is the link???
Hi guys! After some testing I have found out that my Intel Atom 330 CPU and nVidia ION AsRock computer actually works and is powerful enough for Live Conversion use! The biggest difference is in which Alpha release you use. If you use Alpha 3 the Live Conversion doesn't work very well. The video goes black after some seconds and just the sound is available. If you switch to the older Alpha 2 it works like a charm!!

Just to make clear, I am talking about streaming over 3G or WiFi over a WAN connection...

Hope this helps...
th3joker wrote:Did the new build get posted anywhere yet?


Here you go - Alpha 3: http://inmethod.com/air-video/download/linux/alpha3/AirVideoServerLinux.jar

th3joker wrote:And the cpu is?


I thought of buying a cheap used 1,6GHz CPU or a 1,3GHz. You think that will do the job for Live conversion?
th3joker wrote:what's the CPU in that version of the AppleTV?


Sorry, I ment Apple Mac Mini....

I thought of buying a cheap used 1,6GHz CPU or a 1,3GHz. You think that will do the job for Live conversion?
Ok, so it could be that my Intel Dual Core Atom 330 doesn't deal with the Live conversion as well as I'd hope for...
I'm running XBMC on it and it rocks!! So it looks like I need a second computer just for running AirVideoServer for Live streaming...

Does anyone know if the 'old' Apple Mac Mini is good enough? I just need a small, quiet and fast enough CPU to run the AirVideoServer on...
So maybe my AsRock running Intel Atom processor isn't fast enough? All this trouble and still not good...
Well... I spoke too soon... The thumbnails and all works good. I can seek through the movie and the correct still-thumbnail works. But after a few seconds of playback the video goes black and the sound is the only thing coming. If I fastforward the movie the video comes for a few seconds again before going black...

Any ideas?
stough wrote:Unknown,

What knome said. The pointer has to be to the executable. It looks like you're pointing to the directory....


OMG!!!! I feel like such an idiot!! I pointed to the directory and didn't include the executable at the end, so the correct path for my configuration is this:


The last ffmpeg made the whole difference!!

Thank you ALL for pitching in and helping out a total n00b like me! I'm going to write a simple step-by-step on my blog later...

By the way, it works like a charm on my AsRock with Atom and nVidia ION chipset - so go nuts if someone else has one!!
I'm so sorry guys! I feel totaly lost! I have made sure that the user that I'm logged in with has the correct permission. I still get the Permission Denied error!

I set the path to: /home/xbmc/Downloads/ffmpeg/ (the ffmpeg executable is within this folder)

Still the error... I'm almost going to cry soon...
Tim...

I just uninstalled the FFMPEG from the Ubuntu Package Installer. Ran the .configure and make command from within my FFMPEG directory, /home/username/Downloads/ffmpeg

I also edited the .properties file to reflect my FFMPEG directory to /home/username/Downloads/ffmpeg

But now I get this error



What am I doing wrong
 
Forum Index » Profile for unknown_inc » Messages posted by unknown_inc
Go to:   
Powered by JForum 2.1.8 © JForum Team