[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Messages posted by: th3joker
Forum Index » Profile for th3joker » Messages posted by th3joker
Author Message
swali wrote:Hi Guys i'm trying to install Alpha 4 on my ubuntu machine. I've downloaded it and done a java -jar AirVideoServerLinux.. i have java installed but get this error


java -jar AirVideoServerLinux.jar
The program 'java' can be found in the following packages:
* gcj-4.4-jre-headless
* openjdk-6-jre-headless
* cacao
* gij-4.3
* jamvm
Try: sudo apt-get install <selected package>
:~/Downloads$ java -jar AirVideoServerLinux.jar
Usage: java -jar AirVideoServerLinux.jar <property-file>
:~/Downloads$ java -jar AirVideoServerLinux.jar install
Error loading properties: /home/swali/Downloads/install (No such file or directory)
java.io.FileNotFoundException: /home/swali/Downloads/install (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at java.io.FileInputStream.<init>(FileInputStream.java:66)
at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:70)
at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:161)
at java.net.URL.openStream(URL.java:1010)
at com.inmethod.air.video.Cli.main(Cli.java:34)

Can anyone help??


You need to install java on your Ubuntu box, this is how to install:

sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner”

sudo apt-get update

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

java -version
Where's alpha4 ? do you have a linky
admin posted an update to alpha 3 was imminent I just wondered if it had been made public yet.
Did the new build get posted anywhere yet?
It was the cache files which are written in the home directory of the user it's run with.

I deleted the .air-video-server folder and it's all working again
Could this be related to IOS4 because I'm having problems running it from my Mac Pro too.

It's ok as long as I only have one source folder when it's more than one only one works.
I can't seem to get it working again.

It seems to startup ok but when you try to connect to the server the bit where the content folders usually pop up are missing.

If I switch back to the old build (alpha 2) I get the server too old error when connecting. When I use alpha 3 i get no error just no folders. It's like the test.properties file isn't feeding the folder data to the app or the app isn't parsing the directories.
Is there some kind of cache kept for the content and thumbnails of each folder that I could delete?

This is what I get when I run it manually:

DEBUG: SnapshotCache: Initializing Thumbnail Cache; Java Version: 1.6.0_20
DEBUG: SnapshotCache: Loaded existing Snapshot Index BTree with with 88 items.2010-07-05 15:44:48.134::INFO: Logging to STDERR via org.mortbay.log.StdErrLog
2010-07-05 15:44:48.152::INFO: jetty-6.1.x
2010-07-05 15:44:48.176::INFO: Started SocketConnector@0.0.0.0:45631

Are there any other logs I can check for errors, is there a way to initialize the app in debug mode so I can see what the problem is.
I had one of the old MacMini's with the intel CPU's and upgraded the CPU in it to a faster dual core which worked fine, depends which one you have in yours.

I reckon you need at least a dual core, in fact I think the minimum spec is Intel Core Duo posted on the main page.
And the cpu is?
what's the CPU in that version of the AppleTV?
The offline conversion seems to work ok on the lower powered stuff it's just if you have enough space to keep duplicates.
I found these posts with Intel Atom mentioned:

http://www.inmethod.com/forum/posts/list/475.page

http://forum.synology.com/enu/viewtopic.php?f=114&t=25252

I ended up upgrading my cpu when I ran tests.

though the ffmpeg output showed a lot of dropped frames and it was pretty obvious what the problem was on mine.
try setting the ownership and permissions on the ffmpeg binary to the user you are running the jar with
After I compiled ffmpeg I moved it to /usr/local/bin and changed the test.properties file to correspond to that.
 
Forum Index » Profile for th3joker » Messages posted by th3joker
Go to:   
Powered by JForum 2.1.8 © JForum Team