[Logo] Air Video Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 
[Moderation Log] Moderation Log   [Register] Register / 
[Login] Login 
Messages posted by: nawunk
Forum Index » Profile for nawunk » Messages posted by nawunk
Author Message
Finally figured out my issue with libav on Freebsd (and possibly freenas?). Apparently my issue was caused by the default gcc 4.2 version shipped with FreeBSD 9. I tried with gcc 4.6 after noticing comments here and it works great!
All you need to do is install gcc from ports (in my case I used lang/gcc46 as it was already installed).
Then use something like this for the configure:
./configure --prefix=/usr/local/airvideo/libav --enable-pthreads --disable-shared --enable-static --enable-gpl --enable-libx264 --enable-libmp3lame --enable-nonfree --enable-libfaac --extra-ldflags="-L/usr/local/lib" --extra-cflags="-I/usr/local/include" --cc=gcc46
I did some more testing, it seems to happen with all h264 files unless you're using live conversion.

it shows the below over and over in the airvideo log:


I double checked that the prior version worked, so I've rolled back to that for now but it'd be good to get 10-bit h264 videos working.
Anyone got the new version with libav to work with FreeBSD? (9.0 x64).

When I try to use .mkv's it doesn't render it properly (see attached for what it looks like).
Any chance on updating the linux version to 2.4.5-beta7 for 10 bit support?
pieman wrote:Got the problem sorted by downloading and compiling x264, and by dropping libfaad out of the ./configure. I also added libtheora and libvorbis.

However I still can't convert /mkv files - is there something I missed in compiling ffmpeg for this?

SJ


Try compiling ffmpeg without --disable-decoder=aac
Legend. Thanks for that lebennebel. That compiled fine, just need to wait until I'm home before I can give it a go.

Thanks
Has anyone managed to compile ffmpeg for 2.4.5-beta3 with alpha 5? Using the ./configure options in this thread I got ffmpeg for 2.2.5 to compile but the same options don't work with the latest.
 
Forum Index » Profile for nawunk » Messages posted by nawunk
Go to:   
Powered by JForum 2.1.8 © JForum Team